Error on RecyclerView Basics in Jetback

I did a fresh import of the Jetpack master source code. I built it without making any changes and got an error on RecyclerView Basics.

I think I need to add a dependency in my gradle build but I don’t know what it is. Here is a screenshot of the error I get.

That appears to be a bug somewhere either in a Lint rule or in the IDE. If you run the app, it compiles and runs fine. I will file a bug report for that later today. Thanks for pointing this out!

BTW, if you want to get rid of the erroneous error, try adding androidx.lifecycle:lifecycle-viewmodel:2.2.0 as a dependency, as that is where HasDefaultViewModelProviderFactory is defined.

FWIW, https://issuetracker.google.com/issues/152245564 is for this issue. I don’t see the problem with androidx.appcompat:appcompat:1.2.0-alpha03.